Global Inbound and Outbound Phone issues

Incident Report for Sentinel Data Solutions

Resolved

This incident has been confirmed to be resolved and services should now fully resume.
Posted Jul 10, 2025 - 10:08 BST

Monitoring

A fix has been implemented and we are monitoring the situation.
Posted Jul 09, 2025 - 21:00 BST

Identified

Further identified issues have been reported, this is being investigated further.
Posted Jul 09, 2025 - 12:51 BST

Monitoring

Most phone services should now be restored. The situation is being monitored for any continued faults.
Posted Jul 09, 2025 - 11:55 BST

Identified

Phone traffic is being rerouted and calls should shortly be operational.
Posted Jul 09, 2025 - 11:44 BST

Investigating

We are currently investigating an global phone issue with calls being silent inbound, outbound and internal calls. This will effect desk and softphones.
Posted Jul 09, 2025 - 11:36 BST
This incident affected: Contacting us/ Tools/ Portals (Telephone System).