Compromised email

Incident Report for Sentinel Data Solutions

Resolved

The offending email has been blocked from all Microsoft tenants and deleted from Outlook.
Posted Mar 31, 2025 - 15:30 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2025 - 16:31 GMT

Identified

We understand that an email has gone out from Matthew with a PDF. Please ignore and delete this email and if you have opened can you get in contact with support.
Posted Mar 25, 2025 - 11:48 GMT