Website performance

Incident Report for Sentinel Data Solutions

Resolved

There was a problem with our upstream provider. The issue has been resolved. We are reviewing our infrastructure to ensure that this doesn’t happen again.
Posted May 08, 2025 - 09:03 BST

Identified

We are aware of problems with website performance and are investigating. The latency issues have been escallated with our upstream provider.

Further updates will be made when availabile.
Posted May 07, 2025 - 15:13 BST